Reduce duplicated files in OpenWRT

Bug: 263697604
Test: Manually checking Wi-Fi in CF x86_64 and arm64
Change-Id: I8f74df9d2db93d1669ede04dfa9ca9aadc2f4fe2
diff --git a/Android.bp b/Android.bp
index 2e197f7..8f77b67 100644
--- a/Android.bp
+++ b/Android.bp
@@ -1,36 +1,15 @@
 package {
+    // See: http://go/android-license-faq
+    // A large-scale-change added 'default_applicable_licenses' to import
+    // all of the 'license_kinds' from "external_openwrt-prebuilts_license"
+    // to get the below license kinds:
+    //   SPDX-license-identifier-Apache-2.0
+    //   SPDX-license-identifier-BSD
+    //   SPDX-license-identifier-GPL-2.0
     default_visibility: ["//visibility:private"],
     default_applicable_licenses: ["external_openwrt-prebuilts_license"],
 }
 
-// Added automatically by a large-scale-change that took the approach of
-// 'apply every license found to every target'. While this makes sure we respect
-// every license restriction, it may not be entirely correct.
-//
-// e.g. GPL in an MIT project might only apply to the contrib/ directory.
-//
-// Please consider splitting the single license below into multiple licenses,
-// taking care not to lose any license_kind information, and overriding the
-// default license using the 'licenses: [...]' property on targets as needed.
-//
-// For unused files, consider creating a 'fileGroup' with "//visibility:private"
-// to attach the license to, and including a comment whether the files may be
-// used in the current project.
-// See: http://go/android-license-faq
-license {
-    name: "external_openwrt-prebuilts_license",
-    visibility: [":__subpackages__"],
-    license_kinds: [
-        "SPDX-license-identifier-Apache-2.0",
-        "SPDX-license-identifier-BSD",
-        "SPDX-license-identifier-GPL-2.0",
-        "SPDX-license-identifier-OpenSSL",
-    ],
-    license_text: [
-        "LICENSE",
-    ],
-}
-
 filegroup {
     name: "openwrt_license_files",
     visibility: [":__subpackages__"],
@@ -41,7 +20,7 @@
 }
 
 license {
-    name: "openwrt_license",
+    name: "external_openwrt-prebuilts_license",
     visibility: [":__subpackages__"],
     license_kinds: [
         "SPDX-license-identifier-Apache-2.0",
@@ -58,3 +37,131 @@
         "HOW_TO_GET_SOURCE_CODE",
     ],
 }
+
+genrule {
+    name: "openwrt_rootfs_base_img_x86_64",
+    srcs: [
+        "x86_64/images/openwrt-22.03.2-x86-64-generic-squashfs-rootfs.img.gz",
+    ],
+    out: ["base_rootfs_x86_64.img"],
+    cmd: "cp $(in) $(genDir) && gzip -d $(genDir)/* && cp $(genDir)/* $(out)",
+}
+
+genrule {
+    name: "openwrt_rootfs_base_img_aarch64",
+    srcs: [
+        "arm64/images/openwrt-22.03.2-armvirt-64-rootfs-squashfs.img.gz",
+    ],
+    out: ["base_rootfs_aarch64.img"],
+    cmd: "cp $(in) $(genDir) && gzip -d $(genDir)/* && cp $(genDir)/* $(out)",
+}
+
+genrule {
+    name: "openwrt_customization_x86_64",
+    tools: [
+        "make_f2fs",
+        "sload_f2fs",
+    ],
+    srcs: [
+        ":openwrt_license_files",
+        "x86_64/kmods/*",
+        "x86_64/packages/*",
+        "shared/uci-defaults/*",
+        "shared/config/*",
+    ],
+    out: ["customization_x86_64.img"],
+    cmd: "mkdir -p $(genDir)/root/upper/etc/uci-defaults && " +
+         "mkdir -p $(genDir)/root/upper/ipks && " +
+         "mkdir -p $(genDir)/root/upper/etc/config && " +
+         "cp $(in) $(genDir)/ && " +
+         "mv $(genDir)/*.ipk $(genDir)/root/upper/ipks && " +
+         "mv $(genDir)/LICENSE $(genDir)/HOW_TO_GET_SOURCE_CODE $(genDir)/root/upper && " +
+         "mv $(genDir)/0_default_config $(genDir)/root/upper/etc/uci-defaults && " +
+         "find $(genDir) -maxdepth 1 -type f -exec mv {} $(genDir)/root/upper/etc/config \\; && " +
+         "ln -s 2 $(genDir)/root/.fs_state && " +
+         "truncate -s 128M $(out) && " +
+         "$(location make_f2fs) $(out) && " +
+         "$(location sload_f2fs) -f $(genDir)/root -t / $(out)",
+}
+
+genrule {
+    name: "openwrt_customization_aarch64",
+    tools: [
+        "make_f2fs",
+        "sload_f2fs",
+    ],
+    srcs: [
+        ":openwrt_license_files",
+        "arm64/kmods/*",
+        "arm64/packages/*",
+        "shared/uci-defaults/*",
+        "shared/config/*",
+    ],
+    out: ["customization_aarch64.img"],
+    cmd: "mkdir -p $(genDir)/root/upper/etc/uci-defaults && " +
+         "mkdir -p $(genDir)/root/upper/ipks && " +
+         "mkdir -p $(genDir)/root/upper/etc/config && " +
+         "cp $(in) $(genDir)/ && " +
+         "mv $(genDir)/*.ipk $(genDir)/root/upper/ipks && " +
+         "mv $(genDir)/LICENSE $(genDir)/HOW_TO_GET_SOURCE_CODE $(genDir)/root/upper && " +
+         "mv $(genDir)/0_default_config $(genDir)/root/upper/etc/uci-defaults && " +
+         "find $(genDir) -maxdepth 1 -type f -exec mv {} $(genDir)/root/upper/etc/config \\; && " +
+         "ln -s 2 $(genDir)/root/.fs_state && " +
+         "truncate -s 128M $(out) && " +
+         "$(location make_f2fs) $(out) && " +
+         "$(location sload_f2fs) -f $(genDir)/root -t / $(out)",
+}
+
+genrule {
+    name: "combined_openwrt_rootfs_x86_64",
+    tools: [
+        "append_squashfs_overlay",
+    ],
+    srcs: [
+        ":openwrt_rootfs_base_img_x86_64",
+        ":openwrt_customization_x86_64",
+    ],
+    out: ["openwrt_rootfs_x86_64.img"],
+    cmd: "$(location append_squashfs_overlay) $(in) $(out) -w",
+}
+
+genrule {
+    name: "combined_openwrt_rootfs_aarch64",
+    tools: [
+        "append_squashfs_overlay",
+    ],
+    srcs: [
+        ":openwrt_rootfs_base_img_aarch64",
+        ":openwrt_customization_aarch64",
+    ],
+    out: ["openwrt_rootfs_aarch64.img"],
+    cmd: "$(location append_squashfs_overlay) $(in) $(out) -w",
+}
+
+prebuilt_etc_host {
+    name: "openwrt_rootfs_x86_64",
+    src: ":combined_openwrt_rootfs_x86_64",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
+
+prebuilt_etc_host {
+    name: "openwrt_rootfs_aarch64",
+    src: ":combined_openwrt_rootfs_aarch64",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
+
+prebuilt_etc_host {
+    name: "openwrt_kernel_x86_64",
+    src: "x86_64/images/openwrt-22.03.2-x86-64-generic-kernel.bin",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
+
+prebuilt_etc_host {
+    name: "openwrt_kernel_aarch64",
+    src: "arm64/images/openwrt-22.03.2-armvirt-64-Image",
+    sub_dir: "openwrt/images",
+    visibility: ["//device/google/cuttlefish/build"],
+}
diff --git a/arm/Android.bp b/arm/Android.bp
deleted file mode 100644
index b7b557b..0000000
--- a/arm/Android.bp
+++ /dev/null
@@ -1,74 +0,0 @@
-package {
-    // See: http://go/android-license-faq
-    // A large-scale-change added 'default_applicable_licenses' to import
-    // all of the 'license_kinds' from "openwrt_license"
-    // to get the below license kinds:
-    //   SPDX-license-identifier-Apache-2.0
-    //   SPDX-license-identifier-BSD
-    //   SPDX-license-identifier-GPL-2.0
-    default_applicable_licenses: ["openwrt_license"],
-}
-
-genrule {
-    name: "openwrt_customization_aarch64",
-    tools: [
-        "make_f2fs",
-        "sload_f2fs",
-    ],
-    srcs: [
-        ":openwrt_license_files",
-        "kmods/*",
-        "packages/*",
-        "uci-defaults/*",
-        "config/*",
-    ],
-    out: ["customization.img"],
-    cmd: "mkdir -p $(genDir)/root/upper/etc/uci-defaults && " +
-         "mkdir -p $(genDir)/root/upper/ipks && " +
-         "mkdir -p $(genDir)/root/upper/etc/config && " +
-         "cp $(in) $(genDir)/ && " +
-         "mv $(genDir)/*.ipk $(genDir)/root/upper/ipks && " +
-         "mv $(genDir)/LICENSE $(genDir)/HOW_TO_GET_SOURCE_CODE $(genDir)/root/upper && " +
-         "mv $(genDir)/0_default_config $(genDir)/root/upper/etc/uci-defaults && " +
-         "find $(genDir) -maxdepth 1 -type f -exec mv {} $(genDir)/root/upper/etc/config \\; && " +
-         "ln -s 2 $(genDir)/root/.fs_state && " +
-         "truncate -s 128M $(out) && " +
-         "$(location make_f2fs) $(out) && " +
-         "$(location sload_f2fs) -f $(genDir)/root -t / $(out)",
-}
-
-genrule {
-    name: "openwrt_rootfs_base_img_aarch64",
-    srcs: [
-        "images/openwrt-22.03.2-armvirt-64-rootfs-squashfs.img.gz",
-    ],
-    out: ["base_rootfs.img"],
-    cmd: "cp $(in) $(genDir) && gzip -d $(genDir)/* && cp $(genDir)/* $(out)",
-}
-
-genrule {
-    name: "combined_openwrt_rootfs_aarch64",
-    tools: [
-        "append_squashfs_overlay",
-    ],
-    srcs: [
-        ":openwrt_rootfs_base_img_aarch64",
-        ":openwrt_customization_aarch64",
-    ],
-    out: ["openwrt_rootfs.img"],
-    cmd: "$(location append_squashfs_overlay) $(in) $(out) -w",
-}
-
-prebuilt_etc_host {
-    name: "openwrt_rootfs_aarch64",
-    src: ":combined_openwrt_rootfs_aarch64",
-    sub_dir: "openwrt/images",
-    visibility: ["//device/google/cuttlefish/build"],
-}
-
-prebuilt_etc_host {
-    name: "openwrt_kernel_aarch64",
-    src: "images/openwrt-22.03.2-armvirt-64-Image",
-    sub_dir: "openwrt/images",
-    visibility: ["//device/google/cuttlefish/build"],
-}
diff --git a/arm/images/openwrt-22.03.2-armvirt-64-Image b/arm64/images/openwrt-22.03.2-armvirt-64-Image
similarity index 100%
rename from arm/images/openwrt-22.03.2-armvirt-64-Image
rename to arm64/images/openwrt-22.03.2-armvirt-64-Image
Binary files differ
diff --git a/arm/images/openwrt-22.03.2-armvirt-64-rootfs-squashfs.img.gz b/arm64/images/openwrt-22.03.2-armvirt-64-rootfs-squashfs.img.gz
similarity index 100%
rename from arm/images/openwrt-22.03.2-armvirt-64-rootfs-squashfs.img.gz
rename to arm64/images/openwrt-22.03.2-armvirt-64-rootfs-squashfs.img.gz
Binary files differ
diff --git a/arm/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-aead_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-aead_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-aead_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-aead_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-ccm_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-ccm_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-ccm_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-ccm_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-cmac_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-cmac_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-cmac_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-cmac_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-crc32c_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-crc32c_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-crc32c_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-crc32c_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-ctr_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-ctr_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-ctr_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-ctr_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-gcm_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-gcm_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-gcm_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-gcm_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-gf128_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-gf128_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-gf128_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-gf128_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-ghash_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-ghash_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-ghash_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-ghash_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-hash_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-hash_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-hash_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-hash_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-hmac_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-hmac_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-hmac_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-hmac_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-manager_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-manager_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-manager_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-manager_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-null_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-null_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-null_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-null_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-rng_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-rng_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-rng_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-rng_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-seqiv_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-seqiv_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-seqiv_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-seqiv_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-crypto-sha256_5.10.146-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-crypto-sha256_5.10.146-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-crypto-sha256_5.10.146-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-crypto-sha256_5.10.146-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk b/arm64/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
rename to arm64/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/packages/hostapd-common_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk b/arm64/packages/hostapd-common_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/packages/hostapd-common_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk
rename to arm64/packages/hostapd-common_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk b/arm64/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk
rename to arm64/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/packages/iw_5.16-1_aarch64_cortex-a53.ipk b/arm64/packages/iw_5.16-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/packages/iw_5.16-1_aarch64_cortex-a53.ipk
rename to arm64/packages/iw_5.16-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/packages/iwinfo_2022-08-19-0dad3e66-1_aarch64_cortex-a53.ipk b/arm64/packages/iwinfo_2022-08-19-0dad3e66-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/packages/iwinfo_2022-08-19-0dad3e66-1_aarch64_cortex-a53.ipk
rename to arm64/packages/iwinfo_2022-08-19-0dad3e66-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/packages/libopenssl1.1_1.1.1s-1_aarch64_cortex-a53.ipk b/arm64/packages/libopenssl1.1_1.1.1s-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/packages/libopenssl1.1_1.1.1s-1_aarch64_cortex-a53.ipk
rename to arm64/packages/libopenssl1.1_1.1.1s-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/packages/libubus20220601_2022-06-01-2bebf93c-1_aarch64_cortex-a53.ipk b/arm64/packages/libubus20220601_2022-06-01-2bebf93c-1_aarch64_cortex-a53.ipk
similarity index 100%
rename from arm/packages/libubus20220601_2022-06-01-2bebf93c-1_aarch64_cortex-a53.ipk
rename to arm64/packages/libubus20220601_2022-06-01-2bebf93c-1_aarch64_cortex-a53.ipk
Binary files differ
diff --git a/arm/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk b/arm64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
similarity index 100%
rename from arm/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
rename to arm64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
Binary files differ
diff --git a/arm/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk b/arm64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
similarity index 100%
rename from arm/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
rename to arm64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
Binary files differ
diff --git a/arm/packages/wireless-regdb_2022.08.12-1_all.ipk b/arm64/packages/wireless-regdb_2022.08.12-1_all.ipk
similarity index 100%
rename from arm/packages/wireless-regdb_2022.08.12-1_all.ipk
rename to arm64/packages/wireless-regdb_2022.08.12-1_all.ipk
Binary files differ
diff --git a/arm/config/dhcp b/shared/config/dhcp
similarity index 100%
rename from arm/config/dhcp
rename to shared/config/dhcp
diff --git a/arm/config/firewall b/shared/config/firewall
similarity index 100%
rename from arm/config/firewall
rename to shared/config/firewall
diff --git a/arm/config/network b/shared/config/network
similarity index 100%
rename from arm/config/network
rename to shared/config/network
diff --git a/arm/config/system b/shared/config/system
similarity index 100%
rename from arm/config/system
rename to shared/config/system
diff --git a/arm/config/wireless b/shared/config/wireless
similarity index 100%
rename from arm/config/wireless
rename to shared/config/wireless
diff --git a/arm/uci-defaults/0_default_config b/shared/uci-defaults/0_default_config
similarity index 100%
rename from arm/uci-defaults/0_default_config
rename to shared/uci-defaults/0_default_config
diff --git a/x86/Android.bp b/x86/Android.bp
deleted file mode 100644
index ea8ed25..0000000
--- a/x86/Android.bp
+++ /dev/null
@@ -1,74 +0,0 @@
-package {
-    // See: http://go/android-license-faq
-    // A large-scale-change added 'default_applicable_licenses' to import
-    // all of the 'license_kinds' from "openwrt_license"
-    // to get the below license kinds:
-    //   SPDX-license-identifier-Apache-2.0
-    //   SPDX-license-identifier-BSD
-    //   SPDX-license-identifier-GPL-2.0
-    default_applicable_licenses: ["openwrt_license"],
-}
-
-genrule {
-    name: "openwrt_customization_x86_64",
-    tools: [
-        "make_f2fs",
-        "sload_f2fs",
-    ],
-    srcs: [
-        ":openwrt_license_files",
-        "kmods/*",
-        "packages/*",
-        "uci-defaults/*",
-        "config/*",
-    ],
-    out: ["customization.img"],
-    cmd: "mkdir -p $(genDir)/root/upper/etc/uci-defaults && " +
-         "mkdir -p $(genDir)/root/upper/ipks && " +
-         "mkdir -p $(genDir)/root/upper/etc/config && " +
-         "cp $(in) $(genDir)/ && " +
-         "mv $(genDir)/*.ipk $(genDir)/root/upper/ipks && " +
-         "mv $(genDir)/LICENSE $(genDir)/HOW_TO_GET_SOURCE_CODE $(genDir)/root/upper && " +
-         "mv $(genDir)/0_default_config $(genDir)/root/upper/etc/uci-defaults && " +
-         "find $(genDir) -maxdepth 1 -type f -exec mv {} $(genDir)/root/upper/etc/config \\; && " +
-         "ln -s 2 $(genDir)/root/.fs_state && " +
-         "truncate -s 128M $(out) && " +
-         "$(location make_f2fs) $(out) && " +
-         "$(location sload_f2fs) -f $(genDir)/root -t / $(out)",
-}
-
-genrule {
-    name: "openwrt_rootfs_base_img_x86_64",
-    srcs: [
-        "images/openwrt-22.03.2-x86-64-generic-squashfs-rootfs.img.gz",
-    ],
-    out: ["base_rootfs.img"],
-    cmd: "cp $(in) $(genDir) && gzip -d $(genDir)/* && cp $(genDir)/* $(out)",
-}
-
-genrule {
-    name: "combined_openwrt_rootfs_x86_64",
-    tools: [
-        "append_squashfs_overlay",
-    ],
-    srcs: [
-        ":openwrt_rootfs_base_img_x86_64",
-        ":openwrt_customization_x86_64",
-    ],
-    out: ["openwrt_rootfs.img"],
-    cmd: "$(location append_squashfs_overlay) $(in) $(out) -w",
-}
-
-prebuilt_etc_host {
-    name: "openwrt_rootfs_x86_64",
-    src: ":combined_openwrt_rootfs_x86_64",
-    sub_dir: "openwrt/images",
-    visibility: ["//device/google/cuttlefish/build"],
-}
-
-prebuilt_etc_host {
-    name: "openwrt_kernel_x86_64",
-    src: "images/openwrt-22.03.2-x86-64-generic-kernel.bin",
-    sub_dir: "openwrt/images",
-    visibility: ["//device/google/cuttlefish/build"],
-}
diff --git a/x86/config/dhcp b/x86/config/dhcp
deleted file mode 100644
index c55d720..0000000
--- a/x86/config/dhcp
+++ /dev/null
@@ -1,52 +0,0 @@
-config dnsmasq
-	option domainneeded '1'
-	option boguspriv '1'
-	option filterwin2k '0'
-	option localise_queries '1'
-	option rebind_protection '1'
-	option rebind_localhost '1'
-	option local '/lan/'
-	option domain 'lan'
-	option expandhosts '1'
-	option nonegcache '0'
-	option authoritative '1'
-	option readethers '1'
-	option leasefile '/tmp/dhcp.leases'
-	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
-	option nonwildcard '1'
-	option localservice '1'
-	option ednspacket_max '1232'
-
-config dhcp 'lan'
-	option interface 'lan'
-	option start '100'
-	option limit '150'
-	option leasetime '12h'
-	option dhcpv4 'server'
-	option dhcpv6 'server'
-	option ra 'server'
-	option ra_slaac '1'
-	list ra_flags 'managed-config'
-	list ra_flags 'other-config'
-
-config dhcp 'wan'
-	option interface 'wan'
-	option ignore '1'
-
-config odhcpd 'odhcpd'
-	option maindhcp '0'
-	option leasefile '/tmp/hosts/odhcpd'
-	option leasetrigger '/usr/sbin/odhcpd-update'
-	option loglevel '4'
-
-config 'dhcp' 'wifi'
-	option 'interface' 'wifi'
-	option 'start' '100'
-	option 'limit' '150'
-	option 'leasetime' '12h'
-
-config 'dhcp' 'wifi2'
-	option 'interface' 'wifi2'
-	option 'start' '100'
-	option 'limit' '150'
-	option 'leasetime' '12h'
diff --git a/x86/config/firewall b/x86/config/firewall
deleted file mode 100644
index 76f85e7..0000000
--- a/x86/config/firewall
+++ /dev/null
@@ -1,169 +0,0 @@
-config defaults
-	option syn_flood '1'
-	option input 'ACCEPT'
-	option output 'ACCEPT'
-	option forward 'REJECT'
-
-config zone
-	option name wifi
-	list network 'wifi'
-	option input ACCEPT
-	option output ACCEPT
-	option forward REJECT
-
-config 'forwarding'
-	option 'src' 'wifi'
-	option 'dest' 'wan'
-
-config zone
-	option name wifi2
-	list network 'wifi2'
-	option input ACCEPT
-	option output ACCEPT
-	option forward REJECT
-
-config 'forwarding'
-	option 'src' 'wifi2'
-	option 'dest' 'wan'
-
-config zone
-	option name 'lan'
-	list network 'lan'
-	option input 'ACCEPT'
-	option output 'ACCEPT'
-	option forward 'ACCEPT'
-
-config zone
-	option name 'wan'
-	list network 'wan'
-	list network 'wan6'
-	option input 'REJECT'
-	option output 'ACCEPT'
-	option forward 'REJECT'
-	option masq '1'
-	option mtu_fix '1'
-
-config forwarding
-	option src 'lan'
-	option dest 'wan'
-
-config rule
-	option name 'Allow-DHCP-Renew'
-	option src 'wan'
-	option proto 'udp'
-	option dest_port '68'
-	option target 'ACCEPT'
-	option family 'ipv4'
-
-config rule
-	option name 'Allow-Ping'
-	option src 'wan'
-	option proto 'icmp'
-	option icmp_type 'echo-request'
-	option family 'ipv4'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Allow-IGMP'
-	option src 'wan'
-	option proto 'igmp'
-	option family 'ipv4'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Allow-DHCPv6'
-	option src 'wan'
-	option proto 'udp'
-	option src_ip 'fc00::/6'
-	option dest_ip 'fc00::/6'
-	option dest_port '546'
-	option family 'ipv6'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Allow-MLD'
-	option src 'wan'
-	option proto 'icmp'
-	option src_ip 'fe80::/10'
-	list icmp_type '130/0'
-	list icmp_type '131/0'
-	list icmp_type '132/0'
-	list icmp_type '143/0'
-	option family 'ipv6'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Allow-ICMPv6-Input'
-	option src 'wan'
-	option proto 'icmp'
-	list icmp_type 'echo-request'
-	list icmp_type 'echo-reply'
-	list icmp_type 'destination-unreachable'
-	list icmp_type 'packet-too-big'
-	list icmp_type 'time-exceeded'
-	list icmp_type 'bad-header'
-	list icmp_type 'unknown-header-type'
-	list icmp_type 'router-solicitation'
-	list icmp_type 'neighbour-solicitation'
-	list icmp_type 'router-advertisement'
-	list icmp_type 'neighbour-advertisement'
-	option limit '1000/sec'
-	option family 'ipv6'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Allow-ICMPv6-Forward'
-	option src 'wan'
-	option dest '*'
-	option proto 'icmp'
-	list icmp_type 'echo-request'
-	list icmp_type 'echo-reply'
-	list icmp_type 'destination-unreachable'
-	list icmp_type 'packet-too-big'
-	list icmp_type 'time-exceeded'
-	list icmp_type 'bad-header'
-	list icmp_type 'unknown-header-type'
-	option limit '1000/sec'
-	option family 'ipv6'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Allow-IPSec-ESP'
-	option src 'wan'
-	option dest 'lan'
-	option proto 'esp'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Allow-ISAKMP'
-	option src 'wan'
-	option dest 'lan'
-	option dest_port '500'
-	option proto 'udp'
-	option target 'ACCEPT'
-
-config rule
-	option name 'Support-UDP-Traceroute'
-	option src 'wan'
-	option dest_port '33434:33689'
-	option proto 'udp'
-	option family 'ipv4'
-	option target 'REJECT'
-	option enabled 'false'
-
-config include
-	option path '/etc/firewall.user'
-
-config rule
-	option name 'Allow SSH'
-	option src 'wan'
-	option target 'ACCEPT'
-	option proto 'tcp'
-	option dest_port '22'
-
-config rule
-	option name 'Allow LuCI'
-	option src 'wan'
-	option target 'ACCEPT'
-	option proto 'tcp'
-	option dest_port '80 443'
diff --git a/x86/config/network b/x86/config/network
deleted file mode 100644
index b146475..0000000
--- a/x86/config/network
+++ /dev/null
@@ -1,33 +0,0 @@
-config interface 'loopback'
-	option device 'lo'
-	option proto 'static'
-	option ipaddr '127.0.0.1'
-	option netmask '255.0.0.0'
-
-config globals 'globals'
-	option ula_prefix 'fd72:5afb:a7cf::/48'
-
-config device
-	option name 'br-lan'
-	option type 'bridge'
-	list ports 'eth0'
-
-config interface 'wan'
-	option device 'br-lan'
-	option proto 'static'
-	option netmask '255.255.255.0'
-	option ipaddr '192.168.96.2'
-	option ip6assign '30'
-	option gateway '192.168.96.1'
-	option dns '8.8.8.8'
-	option broadcast '192.168.96.3'
-
-config 'interface' 'wifi'
-	option 'proto' 'static'
-	option 'ipaddr' '192.168.2.1'
-	option 'netmask' '255.255.255.0'
-
-config 'interface' 'wifi2'
-	option 'proto' 'static'
-	option 'ipaddr' '192.168.3.1'
-	option 'netmask' '255.255.255.0'
\ No newline at end of file
diff --git a/x86/config/system b/x86/config/system
deleted file mode 100644
index 269b7f7..0000000
--- a/x86/config/system
+++ /dev/null
@@ -1,15 +0,0 @@
-config system
-	option hostname 'OpenWrt'
-	option timezone 'UTC'
-	option ttylogin '0'
-	option log_size '64'
-	option urandom_seed '0'
-	option log_file '/dev/hvc0'
-
-config timeserver 'ntp'
-	option enabled '1'
-	option enable_server '0'
-	list server '0.openwrt.pool.ntp.org'
-	list server '1.openwrt.pool.ntp.org'
-	list server '2.openwrt.pool.ntp.org'
-	list server '3.openwrt.pool.ntp.org'
diff --git a/x86/config/wireless b/x86/config/wireless
deleted file mode 100644
index b91cbdf..0000000
--- a/x86/config/wireless
+++ /dev/null
@@ -1,29 +0,0 @@
-config wifi-device 'radio0'
-	option type 'mac80211'
-	option channel '36'
-	option hwmode '11a'
-	option path 'virtual/mac80211_hwsim/hwsim0'
-	option htmode 'VHT80'
-	option disabled '0'
-
-config wifi-iface 'default_radio0'
-	option device 'radio0'
-	option mode 'ap'
-	option encryption 'none'
-	option network 'wifi'
-	option ssid 'VirtWifi'
-
-config wifi-device 'radio1'
-	option type 'mac80211'
-	option channel '36'
-	option hwmode '11a'
-	option path 'virtual/mac80211_hwsim/hwsim1'
-	option htmode 'VHT80'
-	option disabled '0'
-
-config wifi-iface 'default_radio1'
-	option device 'radio1'
-	option mode 'ap'
-	option encryption 'none'
-	option network 'wifi2'
-	option ssid 'VirtWifi2'
diff --git a/x86/uci-defaults/0_default_config b/x86/uci-defaults/0_default_config
deleted file mode 100644
index 093006f..0000000
--- a/x86/uci-defaults/0_default_config
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-opkg install /ipks/*
-ip link set eth0 mtu 1460
-reboot
diff --git a/x86/images/openwrt-22.03.2-x86-64-generic-kernel.bin b/x86_64/images/openwrt-22.03.2-x86-64-generic-kernel.bin
similarity index 100%
rename from x86/images/openwrt-22.03.2-x86-64-generic-kernel.bin
rename to x86_64/images/openwrt-22.03.2-x86-64-generic-kernel.bin
Binary files differ
diff --git a/x86/images/openwrt-22.03.2-x86-64-generic-squashfs-rootfs.img.gz b/x86_64/images/openwrt-22.03.2-x86-64-generic-squashfs-rootfs.img.gz
similarity index 100%
rename from x86/images/openwrt-22.03.2-x86-64-generic-squashfs-rootfs.img.gz
rename to x86_64/images/openwrt-22.03.2-x86-64-generic-squashfs-rootfs.img.gz
Binary files differ
diff --git a/x86/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_x86_64.ipk b/x86_64/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_x86_64.ipk
rename to x86_64/kmods/kmod-cfg80211_5.10.146+5.15.58-1-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-aead_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-aead_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-aead_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-aead_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-ccm_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-ccm_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-ccm_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-ccm_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-cmac_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-cmac_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-cmac_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-cmac_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-crc32c_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-crc32c_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-crc32c_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-crc32c_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-ctr_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-ctr_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-ctr_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-ctr_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-gcm_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-gcm_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-gcm_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-gcm_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-gf128_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-gf128_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-gf128_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-gf128_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-ghash_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-ghash_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-ghash_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-ghash_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-hash_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-hash_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-hash_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-hash_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-hmac_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-hmac_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-hmac_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-hmac_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-manager_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-manager_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-manager_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-manager_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-null_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-null_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-null_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-null_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-rng_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-rng_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-rng_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-rng_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-seqiv_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-seqiv_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-seqiv_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-seqiv_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-crypto-sha256_5.10.146-1_x86_64.ipk b/x86_64/kmods/kmod-crypto-sha256_5.10.146-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-crypto-sha256_5.10.146-1_x86_64.ipk
rename to x86_64/kmods/kmod-crypto-sha256_5.10.146-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_x86_64.ipk b/x86_64/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_x86_64.ipk
rename to x86_64/kmods/kmod-mac80211-hwsim_5.10.146+5.15.58-1-1_x86_64.ipk
Binary files differ
diff --git a/x86/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_x86_64.ipk b/x86_64/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_x86_64.ipk
similarity index 100%
rename from x86/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_x86_64.ipk
rename to x86_64/kmods/kmod-mac80211_5.10.146+5.15.58-1-1_x86_64.ipk
Binary files differ
diff --git a/x86/packages/hostapd-common_2022-01-16-cff80b4f-14.1_x86_64.ipk b/x86_64/packages/hostapd-common_2022-01-16-cff80b4f-14.1_x86_64.ipk
similarity index 100%
rename from x86/packages/hostapd-common_2022-01-16-cff80b4f-14.1_x86_64.ipk
rename to x86_64/packages/hostapd-common_2022-01-16-cff80b4f-14.1_x86_64.ipk
Binary files differ
diff --git a/x86/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_x86_64.ipk b/x86_64/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_x86_64.ipk
similarity index 100%
rename from x86/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_x86_64.ipk
rename to x86_64/packages/hostapd-openssl_2022-01-16-cff80b4f-14.1_x86_64.ipk
Binary files differ
diff --git a/x86/packages/iw_5.16-1_x86_64.ipk b/x86_64/packages/iw_5.16-1_x86_64.ipk
similarity index 100%
rename from x86/packages/iw_5.16-1_x86_64.ipk
rename to x86_64/packages/iw_5.16-1_x86_64.ipk
Binary files differ
diff --git a/x86/packages/iwinfo_2022-08-19-0dad3e66-1_x86_64.ipk b/x86_64/packages/iwinfo_2022-08-19-0dad3e66-1_x86_64.ipk
similarity index 100%
rename from x86/packages/iwinfo_2022-08-19-0dad3e66-1_x86_64.ipk
rename to x86_64/packages/iwinfo_2022-08-19-0dad3e66-1_x86_64.ipk
Binary files differ
diff --git a/x86/packages/libopenssl1.1_1.1.1s-1_x86_64.ipk b/x86_64/packages/libopenssl1.1_1.1.1s-1_x86_64.ipk
similarity index 100%
rename from x86/packages/libopenssl1.1_1.1.1s-1_x86_64.ipk
rename to x86_64/packages/libopenssl1.1_1.1.1s-1_x86_64.ipk
Binary files differ
diff --git a/x86/packages/libubus20220601_2022-06-01-2bebf93c-1_x86_64.ipk b/x86_64/packages/libubus20220601_2022-06-01-2bebf93c-1_x86_64.ipk
similarity index 100%
rename from x86/packages/libubus20220601_2022-06-01-2bebf93c-1_x86_64.ipk
rename to x86_64/packages/libubus20220601_2022-06-01-2bebf93c-1_x86_64.ipk
Binary files differ
diff --git a/x86/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk b/x86_64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
similarity index 100%
rename from x86/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
rename to x86_64/packages/luci-lib-json_git-18.184.37844-cde13dc_all.ipk
Binary files differ
diff --git a/x86/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk b/x86_64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
similarity index 100%
rename from x86/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
rename to x86_64/packages/luci-mod-rpc_git-21.020.56896-af422b1_all.ipk
Binary files differ
diff --git a/x86/packages/wireless-regdb_2022.08.12-1_all.ipk b/x86_64/packages/wireless-regdb_2022.08.12-1_all.ipk
similarity index 100%
rename from x86/packages/wireless-regdb_2022.08.12-1_all.ipk
rename to x86_64/packages/wireless-regdb_2022.08.12-1_all.ipk
Binary files differ