blob: 702d5ddb17743de8e74d195bf14f55ac6565f851 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils multilib toolchain-funcs
DESCRIPTION="A reference open-source implementation of DLNA (Digital Living Network Alliance) standards"
HOMEPAGE="http://libdlna.geexbox.org"
SRC_URI="http://libdlna.geexbox.org/releases/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux"
DEPEND=">=virtual/ffmpeg-0.6.90"
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-libav9.patch
# 540150
epatch "${FILESDIR}"/${P}-ffmpeg.patch
tc-export CC
}
src_configure() {
# I can't use econf
# --host is not implemented in ./configure file
./configure \
--prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/$(get_libdir)" \
--disable-static \
|| die
}
src_compile() {
# not parallel safe, error "cannot find -ldlna"
emake -j1
}