blob: 219f9f54d3ce1f6cbd2c83bacbb5fa0cb1a1ccec [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
KDE_HANDBOOK="optional"
inherit kde4-base
DESCRIPTION="KDE kioslaves from the kdemultimedia package"
KEYWORDS=" ~amd64 ~x86"
IUSE="debug flac vorbis"
DEPEND="
$(add_kdeapps_dep libkcddb)
$(add_kdeapps_dep libkcompactdisc)
media-sound/cdparanoia
flac? ( >=media-libs/flac-1.1.2 )
vorbis? (
media-libs/libogg
media-libs/libvorbis
)
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with flac)
$(cmake-utils_use_with vorbis OggVorbis)
)
kde4-base_src_configure
}