blob: 534a69b0221db1527dd22f8a602463766e5fc26b [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="4"
inherit base
MY_P="${P/_/-}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Primary Rate ISDN (PRI) library"
HOMEPAGE="http://www.asterisk.org/"
SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${MY_P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ~sparc x86"
IUSE="static-libs"
PATCHES=(
"${FILESDIR}/${PN}-1.4.12-multilib.patch"
"${FILESDIR}/${PN}-1.4.12-respect-user-flags.patch"
)
src_install() {
emake INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install
use static-libs || find "${D}" -name '*.a' -delete
dodoc ChangeLog README TODO
}