blob: df5094568761ca71d1662ebb4b43008338dc4d43 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools
IUSE=""
DESCRIPTION="dockapp for monitoring filesystem usage"
HOMEPAGE="http://windowmaker.org/dockapps/?name=wmfsm"
# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
RDEPEND=">=x11-libs/libdockapp-0.7:=
x11-libs/libX11
x11-libs/libXext
x11-libs/libXt
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-proto/xproto"
src_prepare() {
sed -e "/^X11LIBS/s/-I$x_includes //" -i configure.ac || die "sed failed"
eautoreconf
}
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog
}