blob: 4b43cb67b7896d8a1241ea490ff0931227d2d606 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit apache-module eutils multilib
DESCRIPTION="mod_fcgid is a binary-compatible alternative to mod_fastcgi with better process management"
HOMEPAGE="http://httpd.apache.org/mod_fcgid/"
SRC_URI="mirror://apache/httpd/mod_fcgid/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc ~ppc64 x86"
IUSE=""
APACHE2_MOD_CONF="2.2/20_${PN}"
APACHE2_MOD_DEFINE="FCGID"
DOCFILES="CHANGES-FCGID README-FCGID STATUS-FCGID"
need_apache2
src_compile () {
./configure.apxs || die "apxs configure failed!"
make || die "make failed"
ln -sf modules/fcgid/.libs .libs || die "symlink creation failed"
}