blob: 6a2503b6fdfa75126e6bf85e94fcb6729c2dbe60 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit toolchain-funcs
DESCRIPTION="A tool to query or alter a process' scheduling policy"
HOMEPAGE="http://freequaos.host.sk/schedtool"
SRC_URI="http://freequaos.host.sk/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT=0
KEYWORDS="amd64 ~arm ~mips ppc x86 ~amd64-linux ~x86-linux"
IUSE=""
src_prepare() {
sed -i '/^CFLAGS=/d;/^install:/s/install-doc//' Makefile || die
}
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
emake DESTPREFIX="${ED}"/usr install
dodoc CHANGES INSTALL PACKAGERS README SCHED_DESIGN TODO TUNING
}