blob: 17f9f4e7a611442339782134a46a10a15bc0602d [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=3
inherit eutils pam
DESCRIPTION="a simple PAM module which uses libfprint's functionality for authentication"
HOMEPAGE="http://www.reactivated.net/fprint/wiki/Pam_fprint"
SRC_URI="mirror://sourceforge/fprint/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
IUSE=""
RDEPEND="sys-auth/libfprint
sys-libs/pam"
DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-headers.patch
}
src_install() {
dopammod src/${PN}.so || die
newbin src/pamtest pamtest.fprint || die
dobin src/pam_fprint_enroll || die
dodoc AUTHORS ChangeLog NEWS README || die
}