blob: 8cdb3f6cfb5ef7763b8621ffae6024fdc0d597e0 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils fortran-2
DEB_PN=geant321
DEB_PV=${PV}.dfsg
DEB_PR=11
DEB_P=${DEB_PN}_${DEB_PV}
DESCRIPTION="CERN's detector description and simulation Tool"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="
mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.debian.tar.gz"
SLOT="3"
LICENSE="GPL-2 LGPL-2 BSD"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="
x11-libs/motif:0
dev-lang/cfortran
sci-physics/cernlib
sci-physics/paw"
DEPEND="${RDEPEND}
virtual/latex-base
x11-misc/imake
x11-misc/makedepend"
S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
src_prepare() {
mv ../debian . || die
sed -i -e 's:/tmp/dp.*/cern:cern:g' debian/patches/* || die
cp debian/add-ons/Makefile . || die
export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
sed -i \
-e 's:/usr/local:${EROOT}usr:g' \
Makefile || die "sed'ing the Makefile failed"
einfo "Applying Debian patches"
emake -j1 patch
# since we depend on cfortran, do not use the one from cernlib
rm -f src/include/cfortran/cfortran.h
}
src_compile() {
# create local LaTeX cache directory
VARTEXFONTS="${T}"/fonts
emake -j1 cernlib-indep cernlib-arch
}
src_test_() {
LD_LIBRARY_PATH="${S}"/shlib emake -j1 cernlib-test
}
src_install() {
emake DESTDIR="${D}" install
cd debian
dodoc changelog README.* deadpool.txt NEWS copyright
newdoc add-ons/README README.add-ons
}