blob: cbe1e8818de04ce9a4c7677c69e627a0d728b85d [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
DESCRIPTION="Experimental x-y data reading library"
HOMEPAGE="http://www.unipress.waw.pl/fityk/xylib/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="bzip2 static-libs zlib"
RDEPEND="
dev-libs/boost
bzip2? ( app-arch/bzip2 )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}"
src_configure() {
econf \
$(use_enable static-libs static) \
$(use_with bzip2 bzlib) \
$(use_with zlib)
}