blob: 8b7e475624abae1e7ce2b899f6f476522162febf [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools-utils multilib
MYPN=CoinMP
DESCRIPTION="COIN-OR lightweight API for COIN-OR libraries CLP, CBC, and CGL"
HOMEPAGE="https://projects.coin-or.org/CoinMP/"
SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
LICENSE="EPL-1.0"
SLOT="0/1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples static-libs"
RDEPEND="sci-libs/coinor-cbc:="
DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
src_prepare() {
# needed for the --with-coin-instdir
dodir /usr
sed -i \
-e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
configure || die
sed -i \
-e '/^addlibsdir/s/$(DESTDIR)//' \
-e 's/$(addlibsdir)/$(DESTDIR)\/$(addlibsdir)/g' \
-e 's/$(DESTDIR)$(DESTDIR)/$(DESTDIR)/g' \
Makefile.in || die
autotools-utils_src_prepare
}
src_configure() {
local myeconfargs=(
--enable-dependency-linking
--with-coin-instdir="${ED}"/usr
--datadir=/usr/share
)
autotools-utils_src_configure
}
src_test() {
autotools-utils_src_test test
}
src_install() {
autotools-utils_src_install
# already installed
rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
}