blob: 300ea0d09badea8dfc25a74127c0a29037cb798f [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="DHCP Packet Analyzer/tcpdump postprocessor"
HOMEPAGE="http://www.mavetju.org/unix/general.php"
SRC_URI="http://www.mavetju.org/download/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~mips"
RDEPEND="net-libs/libpcap"
DEPEND="
${RDEPEND}
dev-lang/perl
"
src_prepare() {
epatch "${FILESDIR}"/${P}-Makefile.patch
epatch "${FILESDIR}"/${P}-debian.patch
epatch "${FILESDIR}"/${P}-endianness.patch
}
src_compile() {
emake CC=$(tc-getCC)
}
src_install () {
dobin ${PN}
doman ${PN}.8
dodoc CHANGES CONTACT
}