blob: 475af59fc0fbb05f7189e8d878b6be2043306a4b [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils autotools
DESCRIPTION="Synthesizer keyboard emulation package: Moog, Hammond and others"
HOMEPAGE="http://sourceforge.net/projects/bristol"
SRC_URI="mirror://sourceforge/bristol/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="alsa oss static-libs"
# osc : configure option but no code it seems...
# jack: fails to build if disabled
# pulseaudio: not fully supported
RDEPEND=">=media-sound/jack-audio-connection-kit-0.109.2
alsa? ( >=media-libs/alsa-lib-1.0.0 )
x11-libs/libX11"
# osc? ( >=media-libs/liblo-0.22 )
DEPEND="${RDEPEND}
x11-proto/xproto
virtual/pkgconfig"
DOCS=( AUTHORS ChangeLog HOWTO NEWS README )
src_prepare() {
epatch "${FILESDIR}"/${P}-cflags.patch
epatch "${FILESDIR}"/${P}-implicit-dec.patch
eautoreconf
}
src_configure() {
econf \
$(use_enable static-libs static) \
--disable-version-check \
$(use_enable oss) \
$(use_enable alsa)
}
src_install() {
default
prune_libtool_files
}