blob: f2f568c1a7dbb9539a131ee1ca092361c1a46c6b [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit gst-plugins-base gst-plugins10
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="x11-libs/libXv
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-proto/videoproto
x11-proto/xproto
x11-proto/xextproto"
# xshm is a compile time option of xvideo
# x is needed to build any X plugins, but we build/install only xv anyway
GST_PLUGINS_BUILD="x xvideo xshm"
GST_PLUGINS_BUILD_DIR="xvimage"
src_prepare() {
# The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
# though they are not actually used. This needs to be fixed upstream by
# replacing AC_PATH_XTRA with PKG_CONFIG calls.
sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
gst-plugins10_system_link \
gst-libs/gst/video:gstreamer-video \
gst-libs/gst/interfaces:gstreamer-interfaces
}