blob: b80d6eb4c4a6b6ce0248a8424d3b5ad8148bfd39 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
GST_ORG_MODULE=gst-plugins-bad
inherit gstreamer
KEYWORDS="amd64 x86"
IUSE=""
RDEPEND=">=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
GST_PLUGINS_BUILD="schro"
GST_PLUGINS_BUILD_DIR="schroedinger"
src_prepare() {
local pdir=$(gstreamer_get_plugin_dir)
# gstbasevideo has no .pc
sed -e "s:\$(top_builddir)/gst-libs/gst/video/.*\.la:-lgstbasevideo-${SLOT}:" \
-i "${pdir}"/Makefile.{am,in} || die
}