blob: 39e210f24acd0fdcdb8b45b1b15ec4f0dde3f832 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 python-r1
DESCRIPTION="Open Source CAM - Toolpath Generation for 3-Axis CNC machining"
HOMEPAGE="http://pycam.sourceforge.net/"
SRC_URI="https://dev.gentoo.org/~slis/${P}.tar.gz"
LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
SLOT="0"
DEPEND="
dev-python/pygtk
dev-python/pygtkglext
dev-python/pyopengl
"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
src_prepare() {
epatch "${FILESDIR}/fix-export-toolpath.patch"
distutils-r1_src_prepare
}