blob: 740c9dfbae6dbda215e50825580f0b580b4abf99 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils
DESCRIPTION="LXQT session manager"
HOMEPAGE="http://lxqt.org/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi
LICENSE="GPL-2 LGPL-2.1+"
SLOT="0"
S=${WORKDIR}
CDEPEND="dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtgui:4
~lxqt-base/liblxqt-${PV}
~dev-libs/libqtxdg-0.5.3
x11-libs/libX11"
DEPEND="${CDEPEND}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
RDEPEND="${CDEPEND}
~lxqt-base/lxqt-common-${PV}"
src_install(){
cmake-utils_src_install
doman lxqt-config-session/man/*.1 lxqt-session/man/*.1
}