blob: 06aa636c4c6421aaabac0ad5166027447f725e36 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_TEST="none"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.markdown"
inherit ruby-fakegem
DESCRIPTION="Retrieve the source code for a method"
HOMEPAGE="https://github.com/banister/method_source"
IUSE=""
SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
ruby_add_bdepend "test? ( >=dev-ruby/bacon-1.1.0 )"
each_ruby_test() {
${RUBY} -I. -S bacon -k test/test.rb || die "Tests failed."
}