blob: c3891c8543c6ac1ea979049be93ffc8bb3ef1fdf [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PHP_EXT_NAME="memcached"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="README"
USE_PHP="php5-5 php5-4"
inherit php-ext-pecl-r2
KEYWORDS="~amd64 ~x86"
DESCRIPTION="PHP extension for interfacing with memcached via libmemcached library"
LICENSE="PHP-3"
SLOT="0"
IUSE="+session"
DEPEND=">=dev-libs/libmemcached-0.38 sys-libs/zlib
dev-lang/php:*[session?]"
RDEPEND="${DEPEND}"
src_prepare() {
local slot orig_s="${PHP_EXT_S}"
for slot in $(php_get_slots); do
php_init_slot_env ${slot}
epatch "${FILESDIR}/${P}-php54_zend.patch"
done
php-ext-source-r2_src_prepare
}
src_configure() {
my_conf="--enable-memcached
--with-zlib-dir=/usr
$(use_enable session memcached-session)"
php-ext-source-r2_src_configure
}