blob: aa34d78c3d2e48c53895e8fd6d00c4dfa09f5b20 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
MODULE_AUTHOR=SHAY
MODULE_VERSION=1.39
inherit depend.apache perl-module
DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
DEPEND="virtual/perl-ExtUtils-MakeMaker"
# interactive, requires interaction with the live filesystem
SRC_TEST="skip"
need_apache
pkg_setup() {
perl_set_version
}
src_install() {
# This is to avoid conflicts with a deprecated Apache::Test stepping
# in and causing problems/install errors
if [ -f "${S}"/.mypacklist ];
then
rm -f "${S}"/.mypacklist
fi
perl-module_src_install
}