blob: 53e5951a12061f9609d02668d6be8de4558cdd4f [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit cmake-utils multilib
#if LIVE
ESVN_REPO_URI="https://libdivsufsort.googlecode.com/svn/trunk/"
inherit subversion
#endif
DESCRIPTION="Suffix-sorting library (for BWT)"
HOMEPAGE="https://github.com/y-256/libdivsufsort"
SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
#if LIVE
KEYWORDS=
SRC_URI=
#endif
src_prepare() {
# will appreciate saner approach, if there is any
sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
*/CMakeLists.txt || die
}