blob: 7a33e373ef1923ee3ad22a3d582af569def3f227 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="3"
DESCRIPTION="C++ binding to GuiLoader library"
HOMEPAGE="http://www.crowdesigner.org"
SRC_URI="https://nothing-personal.googlecode.com/files/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
LANGS="ru"
RDEPEND=">=dev-libs/guiloader-2.21
>=dev-cpp/gtkmm-2.22:2.4
>=dev-cpp/glibmm-2.24:2"
DEPEND="${RDEPEND}
dev-libs/boost
virtual/pkgconfig
nls? ( >=sys-devel/gettext-0.18 )"
for x in ${LANGS}; do
IUSE="${IUSE} linguas_${x}"
done
src_configure() {
econf $(use_enable nls)
}
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
dodoc doc/{authors.txt,news.en.txt,readme.en.txt} || die
}