blob: 753626194accf5959a0c6dc16f4e9168c4b981bf [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=(python{2_7,3_3,3_4})
inherit distutils-r1 git-2
DESCRIPTION="framework for ebuild generators"
HOMEPAGE="https://github.com/jauhien/g-sorcery"
SRC_URI=""
EGIT_BRANCH="master"
EGIT_REPO_URI="git://git.gentoo.org/proj/g-sorcery.git"
LICENSE="GPL-2"
SLOT="0"
IUSE="bson git"
DEPEND="bson? ( dev-python/pymongo[${PYTHON_USEDEP}] )
git? ( dev-vcs/git )
sys-apps/portage[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
PDEPEND=">=app-portage/layman-2.2.0[g-sorcery(-),${PYTHON_USEDEP}]"
python_test() {
PYTHONPATH="." "${PYTHON}" scripts/run_tests.py
}
python_install_all() {
distutils-r1_python_install_all
doman docs/*.8
dohtml docs/developer_instructions.html
diropts -m0777
dodir /var/lib/g-sorcery
}