blob: 00facf07994d3348e2e957a45f7205d27b95e122 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="3"
DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
HOMEPAGE="http://kldp.net/projects/hangul/"
SRC_URI="http://kldp.net/frs/download.php/5855/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
IUSE="nls static-libs test"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )
virtual/pkgconfig
test? ( dev-libs/check )"
src_configure() {
econf \
$(use_enable nls) \
$(use_enable static-libs static) || die
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README || die
}