blob: 45293cc09b1645c5dbe67cacd59e3fa9e4a46034 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit bash-completion-r1 distutils-r1
DESCRIPTION="Multi-container orchestration for Docker"
HOMEPAGE="https://www.docker.com/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
CDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/dockerpty-0.3.2[${PYTHON_USEDEP}]
<dev-python/dockerpty-0.4[${PYTHON_USEDEP}]
>=dev-python/docker-py-1.0.0[${PYTHON_USEDEP}]
<dev-python/docker-py-1.2[${PYTHON_USEDEP}]
>=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
<dev-python/docopt-0.7[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
<dev-python/pyyaml-4[${PYTHON_USEDEP}]
>=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
<dev-python/six-2[${PYTHON_USEDEP}]
>=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
<dev-python/texttable-0.9[${PYTHON_USEDEP}]
>=dev-python/websocket-client-0.11.0[${PYTHON_USEDEP}]
<dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
"
DEPEND="
test? (
${CDEPEND}
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)
"
RDEPEND="${CDEPEND}"
python_prepare_all() {
local PATCHES=(
"${FILESDIR}"/requests-requirements.patch
)
distutils-r1_python_prepare_all
}
python_test() {
nosetests tests/unit || die "tests failed under ${EPYTHON}"
}
python_install_all() {
newbashcomp contrib/completion/bash/docker-compose ${PN}
distutils-r1_python_install_all
}