blob: d6f9c4c4b1531a2233b4532a52e873c6b1c3ae16 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit toolchain-funcs
DESCRIPTION="A curses-based tool for viewing and analyzing log files"
HOMEPAGE="http://lnav.org"
SRC_URI="https://github.com/tstack/lnav/releases/download/v${PV}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="unicode"
RDEPEND="
app-arch/bzip2
dev-db/sqlite:3
dev-libs/libpcre[cxx]
sys-libs/ncurses[unicode?]
sys-libs/readline:0
sys-libs/zlib"
DEPEND="${RDEPEND}"
src_configure() {
econf \
--disable-static \
$(use_with unicode ncursesw)
}
src_compile() {
emake AR="$(tc-getAR)"
}