blob: e7edbba29c558fd0b76740c6ada7df4cd5a756ee [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
GCONF_DEBUG=no
GNOME2_LA_PUNT=yes
PYTHON_COMPAT=( python2_7 )
inherit autotools gnome2 python-single-r1
DESCRIPTION="Drop-down terminal for GTK+ desktops"
HOMEPAGE="http://guake.org/"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm x86"
RDEPEND="
dev-python/dbus-python
dev-python/gconf-python
dev-python/notify-python
dev-python/pygtk
dev-python/pyxdg
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/vte:0[python]
"
DEPEND="
${RDEPEND}
dev-util/intltool
virtual/pkgconfig
"
DOCS=( AUTHORS ChangeLog NEWS README.rst )
S=${WORKDIR}/${PN}-${P}
src_prepare() {
eautoreconf
# python_fix_shebang does not handle this?
sed -i -e '/^PYTHON=/s|python|'${EPYTHON}'|' src/guake-prefs || die
gnome2_src_prepare
G2CONF="--disable-static"
}
pkg_postinst() {
gnome2_pkg_postinst
}
pkg_postrm() {
gnome2_pkg_postrm
}