blob: 1d3b3d3ce7e7f90506e29d0e3ebbe362f67f6f03 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
#if LIVE
AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
inherit git-r3
#endif
inherit autotools-utils
DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
HOMEPAGE="https://bitbucket.org/mgorny/libtinynotify/"
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc static-libs"
RDEPEND="sys-apps/dbus:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( >=dev-util/gtk-doc-1.18 )"
#if LIVE
KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
>=dev-util/gtk-doc-1.18"
#endif
src_configure() {
myeconfargs=(
$(use_enable debug)
$(use_enable doc gtk-doc)
)
autotools-utils_src_configure
}