blob: 873a58270da61df6825f0b5bbf530d01c341b04d [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
XORG_DRI=dri
inherit linux-info xorg-2
DESCRIPTION="X.Org driver for Intel cards"
KEYWORDS="amd64 x86 ~amd64-fbsd -x86-fbsd"
IUSE="glamor +sna +udev uxa xvmc"
REQUIRED_USE="|| ( glamor sna uxa )"
RDEPEND="x11-libs/libXext
x11-libs/libXfixes
>=x11-libs/pixman-0.27.1
>=x11-libs/libdrm-2.4.29[video_cards_intel]
glamor? (
x11-libs/glamor
)
sna? (
>=x11-base/xorg-server-1.10
)
udev? (
virtual/udev
)
xvmc? (
x11-libs/libXvMC
>=x11-libs/libxcb-1.5
x11-libs/xcb-util
)
"
DEPEND="${RDEPEND}
>=x11-proto/dri2proto-2.6
x11-proto/resourceproto"
src_prepare() {
# wrong variable name, fix configure directly to avoid autoreconf
# see bug #490342
sed -e "s/DRI_CFLAGS/DRI1_CFLAGS/g" -i configure
# see bug #496682
epatch "${FILESDIR}/${PN}-2.21.15-handle-updates-to-DamageUnregister-API.patch"
xorg-2_src_prepare
}
src_configure() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable dri)
$(use_enable glamor)
$(use_enable sna)
$(use_enable uxa)
$(use_enable udev)
$(use_enable xvmc)
)
xorg-2_src_configure
}
pkg_postinst() {
if linux_config_exists \
&& ! linux_chkconfig_present DRM_I915_KMS; then
echo
ewarn "This driver requires KMS support in your kernel"
ewarn " Device Drivers --->"
ewarn " Graphics support --->"
ewarn " Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->"
ewarn " <*> Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver) --->"
ewarn " i915 driver"
ewarn " [*] Enable modesetting on intel by default"
echo
fi
}