blob: 3be1b0c5832f3ed24461188dcb83700967ee3f4f [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="4"
inherit eutils
DESCRIPTION="Program and text file generation"
HOMEPAGE="https://www.gnu.org/software/autogen/"
SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="libopts static-libs"
RDEPEND=">=dev-scheme/guile-1.8
dev-libs/libxml2"
DEPEND="${RDEPEND}"
src_configure() {
# suppress possibly incorrect -R flag
export ag_cv_test_ldflags=
econf $(use_enable static-libs static)
}
src_install() {
default
prune_libtool_files
if ! use libopts ; then
rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
fi
}