blob: b180f981da12f572c3ce511003917b6d1b9770c5 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit autotools eutils fortran-2 toolchain-funcs
MY_PN=UMFPACK
DESCRIPTION="Unsymmetric multifrontal sparse LU factorization library"
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/umfpack"
SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
IUSE="doc"
RDEPEND="
virtual/blas
sci-libs/ufconfig
sci-libs/amd"
DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/${MY_PN}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-autotools.patch
eautoreconf
}
src_compile() {
econf \
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README.txt Doc/ChangeLog || die "dodoc failed"
if use doc; then
insinto /usr/share/doc/${PF}
doins Doc/*.pdf || die "doins failed"
fi
}