blob: 091fc17b463b31ae2820c2ea09cb9042f4216753 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit autotools eutils
MY_PN=CXSparse
DESCRIPTION="Extended sparse matrix package"
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/versions/${MY_PN}-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
IUSE=""
DEPEND="sci-libs/ufconfig"
RDEPEND=""
S="${WORKDIR}/${MY_PN}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-autotools.patch
eautoreconf
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README.txt Doc/ChangeLog || die "dodoc failed"
}