blob: 827fecbd91d3cfe3b6387e18a0c848c0a53738d6 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools-utils multilib
MYPN=Osi
DESCRIPTION="COIN-OR Open Solver Interface"
HOMEPAGE="https://projects.coin-or.org/Osi/"
SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
LICENSE="EPL-1.0"
SLOT="0/1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples glpk static-libs test"
RDEPEND="
sci-libs/coinor-utils:=
glpk? ( sci-mathematics/glpk:= )"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen[dot] )
test? ( sci-libs/coinor-sample )"
S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
src_prepare() {
# needed for the --with-coin-instdir
dodir /usr
sed -i \
-e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
configure || die
autotools-utils_src_prepare
}
src_configure() {
local myeconfargs=(
--enable-dependency-linking
--with-coin-instdir="${ED}"/usr
$(use_with doc dot)
)
if use glpk; then
myeconfargs+=(
--with-glpk-incdir="${EPREFIX}"/usr/include
--with-glpk-lib=-lglpk
)
else
myeconfargs+=( --without-glpk )
fi
autotools-utils_src_configure
}
src_compile() {
autotools-utils_src_compile all $(usex doc doxydoc "")
}
src_test() {
autotools-utils_src_test test
}
src_install() {
use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
autotools-utils_src_install
# already installed
rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
}