blob: 7a1d5c4c975222d4619870d2dca600a44c87f888 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
WX_GTK_VER="2.8"
inherit cmake-utils wxwidgets
MY_PN="climatology_pi"
DESCRIPTION="Climatology Plugin for OpenCPN (includes CL-DATA)"
HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
SRC_URI="
https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
mirror://sourceforge/opencpnplugins/climatology_pi/CL-DATA-1.0.tar.xz -> ${P}-CL-DATA.tar.xz
"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
>=sci-geosciences/opencpn-4.0.0
sys-devel/gettext
"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_PN}-${PV}"
src_install() {
cmake-utils_src_install
insinto "/usr/share/opencpn/plugins/${MY_PN}/data/"
doins "${S}"/{,../}data/*
}