blob: 09df1ecbdcf29f2321a9ef1fafce7096c90f2243 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
WX_GTK_VER="3.0"
inherit cmake-utils wxwidgets
MY_PN="climatology_pi"
DESCRIPTION="Climatology Plugin for OpenCPN (includes CL-DATA)"
HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
SRC_URI="
https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
mirror://sourceforge/opencpnplugins/climatology_pi/CL-DATA-1.0.tar.xz -> ${P}-CL-DATA.tar.xz
"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}
>=sci-geosciences/opencpn-4.0.0
sys-devel/gettext
"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_PN}-${PV}"
src_prepare() {
need-wxwidgets unicode
cmake-utils_src_prepare
}
src_install() {
cmake-utils_src_install
insinto "/usr/share/opencpn/plugins/${MY_PN}/data/"
doins "${S}"/{,../}data/*
}