blob: 5392c272355d93f49a7ff4ecb48c8a952eea86e4 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit toolchain-funcs
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="http://dev.yorhel.nl/ncdc"
SRC_URI="http://dev.yorhel.nl/download/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="geoip"
RDEPEND="app-arch/bzip2
dev-db/sqlite:3
dev-libs/glib:2
net-libs/gnutls
sys-libs/ncurses:0[unicode]
sys-libs/zlib
geoip? ( dev-libs/geoip )"
DEPEND="${RDEPEND}
dev-util/makeheaders
virtual/pkgconfig"
src_configure() {
econf $(use_with geoip)
}
src_compile() {
emake AR="$(tc-getAR)"
}