blob: 18bf3fc1c00661ca49cde9cd60c90385181568ef [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit autotools-utils
DESCRIPTION="Transforming bitmaps into vector graphics"
HOMEPAGE="http://potrace.sourceforge.net/"
SRC_URI="http://potrace.sourceforge.net/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="metric static-libs"
RDEPEND="sys-libs/zlib"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog NEWS README )
src_configure() {
local myeconfargs=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--enable-zlib
--with-libpotrace
$(use_enable metric a4)
$(use_enable metric)
)
autotools-utils_src_configure
}