blob: a8e71bca2d13e79070fb0130fb6bfc128404431f [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils
DESCRIPTION="A Qt-based interface to system statistics"
HOMEPAGE="http://lxqt.org/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
SRC_URI="http://downloads.lxqt.org/lxqt/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}"
fi
LICENSE="GPL-2 LGPL-2.1+"
SLOT="0"
RDEPEND="
dev-qt/qtcore:5
"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
"
src_configure() {
local mycmakeargs=(
-DUSE_QT5=ON
)
cmake-utils_src_configure
}