blob: 1d3535579202faff3e6117426f0c677fe809a8dc [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils
DESCRIPTION="Common base library for the LXQt desktop environment"
HOMEPAGE="http://lxqt.org/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~x86"
fi
LICENSE="GPL-2 LGPL-2.1+"
SLOT="0"
S=${WORKDIR}
DEPEND="~dev-libs/libqtxdg-0.5.3
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXfixes
x11-libs/libXrender
dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtgui:4"
RDEPEND="${DEPEND}"