blob: 1da114d467862dfa9d877e34b886f3325d9dc069 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
GCONF_DEBUG="yes"
inherit autotools eutils gnome2
DESCRIPTION="Cinnamon's library for the Desktop Menu fd.o specification"
HOMEPAGE="http://cinnamon.linuxmint.com/"
SRC_URI="https://github.com/linuxmint/cinnamon-menus/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+introspection"
RDEPEND="
>=dev-libs/glib-2.29.15:2
introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
"
DEPEND="${RDEPEND}
dev-libs/gobject-introspection-common
>=dev-util/intltool-0.40
gnome-base/gnome-common
sys-devel/gettext
virtual/pkgconfig
"
src_prepare() {
epatch_user
eautoreconf
gnome2_src_prepare
}
src_configure() {
DOCS="AUTHORS ChangeLog HACKING NEWS README"
gnome2_src_configure \
$(use_enable introspection) \
--disable-static
}