blob: dbaf49b05e55e01d2f587a421a0dbf291ab9ec78 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
DESCRIPTION="CVS/RCS repository grapher"
HOMEPAGE="http://www.akhphd.au.dk/~bertho/cvsgraph"
SRC_URI="http://www.akhphd.au.dk/~bertho/cvsgraph/release/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-alpha amd64 -ia64 ~ppc ~sparc x86"
IUSE="gif jpeg nls png truetype zlib"
DEPEND="media-libs/gd
zlib? ( sys-libs/zlib )
gif? ( media-libs/giflib )
png? ( media-libs/libpng )
jpeg? ( virtual/jpeg )
truetype? ( media-libs/freetype )"
RDEPEND="${DEPEND}"
src_compile() {
econf \
$(use_enable nls) \
$(use_enable gif) \
$(use_enable png) \
$(use_enable jpeg) \
$(use_enable truetype) \
|| die "econf failed"
emake || die "emake failed"
}
src_install () {
dobin cvsgraph
insinto /etc
doins cvsgraph.conf
doman cvsgraph.1 cvsgraph.conf.5
dodoc ChangeLog README AUTHORS contrib/*.php
docinto automatic_documentation ; dodoc contrib/automatic_documentation/*
}