blob: ea5100233851573931c57077016832e79b799ca6 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=3
PYTHON_DEPEND="2"
inherit eutils python
DESCRIPTION="Examines C/C++ source code for security flaws"
HOMEPAGE="http://www.dwheeler.com/flawfinder/"
SRC_URI="http://www.dwheeler.com/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE=""
DEPEND=""
RDEPEND=""
src_prepare() {
epatch "${FILESDIR}"/flawfinder-1.27-whitespace-traceback.patch
}
src_install() {
dobin ${PN}
doman ${PN}.1
dodoc ChangeLog INSTALL.txt README announcement
dodoc flawfinder.pdf
python_convert_shebangs 2 "${ED}"usr/bin/flawfinder
}