blob: 29f5eef84322942ff3300fc6d5395945275b4c91 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
LICENSE="MIT"
SLOT="1"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
IUSE=""
ruby_add_rdepend "
dev-ruby/activesupport:4.2
>=dev-ruby/nokogiri-1.6.0 =dev-ruby/nokogiri-1.6*
>=dev-ruby/rails-deprecated_sanitizer-1.0.1"
each_ruby_test() {
${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
}