blob: c790604505c329b190669b140b30a82b37a868a8 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit twisted-r1
DESCRIPTION="An implementation of the Q2Q protocol"
HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex https://pypi.python.org/pypi/Vertex"
SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
IUSE="libressl"
DEPEND="
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
>=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
dev-python/twisted-core[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
python_install_all() {
distutils-r1_python_install_all
dodoc NAME.txt
}