blob: e110bba05c58f2714599f82085484cf03f5535cf [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_3 )
inherit distutils-r1
MY_PN=${PN/-/.}
DESCRIPTION="oslo.serialization library"
HOMEPAGE="https://launchpad.net/oslo"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="doc test"
# Note: not in tree
#test? ( <dev-python/hacking-0.8[${PYTHON_USEDEP}] )
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-0.8[${PYTHON_USEDEP}]
<dev-python/pbr-1.0[${PYTHON_USEDEP}]
test? (
>=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
<dev-python/hacking-0.11.0[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
>=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
>=dev-python/oslotest-1.2.0[${PYTHON_USEDEP}]
>=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-1.3.0[${PYTHON_USEDEP}]
)
doc? (
>=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
<dev-python/sphinx-1.3[${PYTHON_USEDEP}]
)
"
RDEPEND="
>=dev-python/Babel-1.3[${PYTHON_USEDEP}]
>=dev-python/six-1.7.0[${PYTHON_USEDEP}]
>=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-1.2.0[${PYTHON_USEDEP}]
>=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
"
python_prepare_all() {
use doc && esetup.py build_sphinx
}
# Note: Tests fail due to requiring installation.
#
# Installation appears to fail due ot the use of namespace packages but root
# cause was never truly established.
RESTRICT="test"
python_test() {
distutils_install_for_testing
PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
testr init || die "testr init failed under ${EPYTHON}"
testr run || die "testr run failed under ${EPYTHON}"
}
python_install_all() {
use doc && local HTML_DOCS=( doc/build/html/. )
distutils-r1_python_install_all
}