blob: 7cef3119722e31020cefd9d222294222acfa0fd2 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="A library for various character encodings"
HOMEPAGE="http://code.haskell.org/encoding/"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+systemencoding"
RDEPEND="<dev-haskell/binary-0.8:=[profile?]
dev-haskell/extensible-exceptions:=[profile?]
>=dev-haskell/haxml-1.22:=[profile?] <dev-haskell/haxml-1.25:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/regex-compat:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag systemencoding systemencoding)
}