blob: 38c49ed5cdaeeb1a85364df53bdcd177615241b9 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.3.2.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Levenshtein and restricted Damerau-Levenshtein edit distances"
HOMEPAGE="https://github.com/batterseapower/edit-distance"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE=""
RDEPEND=">=dev-haskell/random-1.0:=[profile?]
>=dev-lang/ghc-6.10.4:="
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.2"
src_prepare() {
sed -e 's@LANGUAGE @LANGUAGE FlexibleContexts, @' \
-i "${S}/Text/EditDistance/STUArray.hs" || die
}
src_configure() {
haskell-cabal_src_configure \
--flag=splitbase \
--flag=-benchmark \
--flag=-tests
}