blob: 49d73000aa894f31e195b4ebcaa6ec0fda861479 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="text file conversion utility that converts ASCII files between the
MSDOS format and the Unix format"
HOMEPAGE="http://tofrodos.sourceforge.net/"
SRC_URI="http://tofrodos.sourceforge.net/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~x86"
IUSE=""
DEPEND=""
RDEPEND=""
S="${WORKDIR}/${PN}/src"
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.7.8-CFLAGS.patch
}
src_compile() {
emake DEBUG=1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)"
}
src_install() {
dobin fromdos
dosym fromdos /usr/bin/todos
doman fromdos.1
}