blob: 4c0130dfae69ba48c9f6f65c70ad6fa93bd2e159 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="2"
inherit depend.apache webapp
DESCRIPTION="Web-based solution for managing scientific literature, references and citations"
HOMEPAGE="http://www.refbase.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64"
IUSE=""
DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
dev-lang/php[mysql,session]
app-admin/webapp-config
app-text/bibutils"
RDEPEND="${DEPEND}"
need_apache
pkg_setup() {
webapp_pkg_setup
}
src_install () {
webapp_src_preinst
DOCS="AUTHORS BUGS ChangeLog NEWS README TODO UPDATE"
dodoc ${DOCS}
# Don't install docs to webroot
rm -f ${DOCS} COPYING INSTALL
cp -R * "${D}"${MY_HTDOCSDIR}
webapp_configfile ${MY_HTDOCSDIR}/initialize
webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install
}