blob: 25335a90966bf3e818a256c298f527e7f9e095ff [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils
DESCRIPTION="Rime support for Fcitx"
HOMEPAGE="http://fcitx-im.org/"
SRC_URI="https://fcitx.googlecode.com/files/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE=""
RDEPEND=">=app-i18n/fcitx-4.2.7
app-i18n/librime
app-i18n/rime-data
x11-libs/libnotify"
DEPEND="${RDEPEND}"
src_prepare() {
# dont build data resource here, already provided by app-i18n/rime-data
sed -i -e 's|add_subdirectory(data)||' CMakeLists.txt || die
}
src_configure() {
local mycmakeargs=(
-DRIME_DATA_DIR=/usr/share/rime-data
)
cmake-utils_src_configure
}